Skip to content

PGP, minél kevesebb szívással

PGP-t akartam installálni, mert a hackermesék és a Cryptonomicon olvasása közben teljesen érthető emberi vágy alakul ki a titkosított emailre. Annyi a gond, hogy a Mac GnuPG honlapján az utolsó hír, hogy a 1.4.5-ös verzió sebezhető, dolgoznak a friss verzió telepítőjén. Illetve ott van az is, hogy akinek igazán fontos, az letöltheti a forrást és lefordíthatja, ehhez valahogy nem volt kedvem.

Rövidre zárva a történetet - kimarad a hosszasan kerestem és a telepítettem régi binárist rész - a finken fent van a már nem hibás 1.4.6-os verzió és a

$ fink --no-use-binary-dist install gnupg

paranccsal telepíthető is. Ha ez megvan, akkor a felhasználói élmény fokozása végett be lehet építeni a Mail.appba a Sente GPGMail pluginjével, a System Preferencesbe a GPGPreferences-zel. Non plus ultraként a Mac GPG oldalán van grafikus felülettel rendelkező kulcspár kezelő app is, hogy a telepítés után már abszolút ne kelljen terminálban dolgozni. (Más kérdés, hogy a kulcsgenerálást nem tudtam működésre bírni benne.)

Amúgy meg lehet oldani FinkCommanderrel is a telepítést, de úgy nincs benne semmi szép.

4 Comments

  1. CDColt wrote:

    Én is pont így jártam! :-)

    A legnagyobb gondom viszont az, hogy nincs kivel titkosított emaileket váltogatni… Ugyanis nagyon-nagyon kevesen használják…

    Thursday, February 1, 2007 at 22:45 | Permalink
  2. Mondanám, hogy linux listákon csak találsz embereket. :) De inkább tartsuk szerencsénknek, hogy az embereknek nincs rá igénye.

    Eleve úgy kezdtem el, hogy felesleges, de érdekes program. Majd igyekszem security freakként megöregedni, grumpy old man van már elég.

    Friday, February 2, 2007 at 15:57 | Permalink
  3. CDColt wrote:

    :-) Majd küldünk levelet Neal Stephensonnak… :-)

    Friday, February 2, 2007 at 20:28 | Permalink
  4. Na, megint én kezdek offtopikolni, de a Spew-ba belenéztél?

    Saturday, February 3, 2007 at 09:17 | Permalink